[kbd] Kbd-1.15.5 fails to loadkeys

Matthew Burgess matthew at linuxfromscratch.org
Tue Dec 11 20:00:50 MSK 2012

On Tue, 11 Dec 2012 14:33:06 +0400, Alexey Gladkov <gladkov.alexey at gmail.com> wrote:
> 11.12.2012 01:20, Matt Burgess wrote:
>> Hi,
>> The Linux From Scratch bootscripts have a snippet that, on my box, does
>> the following in order to convert a legacy (non-UTF-8) keymap to UTF-8:
>> dumpkeys -c "iso-8859-1" | loadkeys -u
>> This fails with the following output:
>> unknown keysym 'compose'
>> <stdin>:693: syntax error
>> syntax error in map file
>> key bindings not changed
>> Loading <stdin>
>> This appears to be a regression from 1.15.3.
> Can you test the fix ?
> http://git.altlinux.org/people/legion/packages/kbd.git?p=kbd.git;a=commit;h=7e06e56157e8431d02e1377cdc44230944203d88

So, firstly, I don't know whether something's not set up right on my host, but just patching loadkeys.analyze.l breaks
the build, as it can't generate the loadkeys.analyze.c file:

[user at host kbd-1.15.5]$ make V=1
make  all-recursive
make[1]: Entering directory `/home/user/sources/kbd-1.15.5'
Making all in src
make[2]: Entering directory `/home/user/sources/kbd-1.15.5/src'
/bin/sh ../config/ylwrap loadkeys.analyze.l .c loadkeys.analyze.c -- : --header-file=/home/user/sources/kbd-1.15.5/src/loadkeys.analyze.h
make[2]: *** [loadkeys.analyze.c] Error 1

Debugging, it's bailing out in the 'else' clause at line 191 of config/ylwrap, which looks a
lot like it doesn't like the odd looking '.c' filename in the above command.

So, then I edited the loadkeys.analyze.c file by hand, as it looked as if that's all the
regeneration would do.  That enabled the build to proceed to completion, but I still get
the same error as before.



More information about the kbd mailing list