[Comm-en] Creating local directory for apt-get

Chad tama4 at amnet.co.cr
Wed Jul 23 19:36:14 MSD 2003

Here is what I have come up with: ****READ ALL AND SEE PROBLEMS AT THE END****

1) need to: apt-get install apt-utils (this will allow you to run 'genbasedir' 

2) need to create the directory structure. I did mine in /home/chad/rep
[chad at localhost rep]$ find

3) edit as root etc/apt/sources.list and add the new repositories and save

# rep
rpm file:/home/chad/rep/ i586 sisyphus
rpm-src file:/home/chad/rep/ i586 sisyphus 

4) download files you want to install *.src.rpm into SRPMS.sisyphus and *.rpm 
into RPMS.sisyphus

5) run 
[chad at localhost rep]$ genbasedir --topdir=/home/chad/rep i586 sisyphus
Components: sisyphus
Processing pkglists... sisyphus done
Processing srclists... done
Creating component releases... done
Updating global release file... done
Appending MD5Sum... sisyphus done
Creating legacy hashfile... sisyphus done
All your base are belong to us!!!

6) the above should create the hashfile, pkglist, etc....check w/:
[chad at localhost rep]$ ls -1 ./i586/base

7) run: find and should see all including files downloaded
[chad at localhost rep]$ find

8) as root
[root at localhost root]# apt-get update

9) New programs should be available via synaptic or apt-get install. Will show 
dependencies etc

10) need to run the 'genbasedir' (see # 5) if you get more programs

a) only files I put into RPMS.sisyphus are available for install. For some 
reason the ones in SRPMS.sisyphus are not (Synaptic can not even see them). 
So far it works fine for anything I put in RPMS.sisyphus (*rpm OR *.src.rpm).

I have tried moving SRPMS.sisyphus under /rep, 
I have tried doing it in both locations.
I have tried moving *.src.rpm's around

I used the following locations for information:

http://atmsk.ru/viewtopic.php?t=68&sid=14f2ab599b81fc45260661c3c8734e43 (in 
konqueror>tools>translate>russian to english)

So, if anyone can help me 'clean' this up. I would appreciate it. I am new at 
this stuff and that is one reason for this post. Maybe someone can point out 
what I did wrong and I can correct it for myself.

More information about the community-en mailing list